error

Addon Error

So, I made this addon from scratch, but when i try to start a new game with it the loading bar stops at 100 and starts flickering. The crash log says this:

Lua Error: /engine/utils.lua:1782: /data-rpg/birth/classes/mage.lua:6: '}' expected (to close '{' at line 4) near 'name'

    At [C]:-1 
    At [C]:-1 error
    At /engine/utils.lua:1782 loadfilemods
    At /engine/Birther.lua:36 loadDefinition
    At /hooks/rpg/load.lua:6 
    At [string "return function(l, self, data) local ok=false..."]:1 
    At /mod/load.lua:271 
    At [C]:-1 require
    At /engine/Module.lua:160 load
    At /engine/Module.lua:955 instanciate
    At /engine/utils.lua:2197 showMainMenu
    At /engine/init.lua:162 
    At [C]:-1 dofile
    At /loader/init.lua:204 

Can anyone tell me what this means?

Syndicate content